
## Contents $$ First part of tutorial KK Z Topics;Contents;Part one;Start;Beginning;Index#This is the first part of the
tutorial
EasyHelp allows you to convert any Word document into a form that can be viewed as
on-line help in Microsoft Windows. The way you do this is to 'mark-up' your
document with #LJTopic#topicsTopic and #LJLink#linksLink.

Above you will see a heading line of text in green. This has already been 'marked up'
as a topic. #LJMarkingATopic#Marking a topicMarkingATopic is easy. Simply
position the cursor on the line of text that you want to be the topic heading and then
click on the 'T' icon on the toolbar.
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## MarkingATopic $$ MarkingATopic KK Z Topics;MarkingATopic#How to Mark a Topic
You are going to mark the heading line above 'How to Mark a Topic' as a
topic. Do the following steps:

1. Put the text cursor before the H of 'How to Mark a Topic' heading above.
2. Now click on the 'T' icon on the toolbar. A dialog box will appear in the

centre of your screen. Simply type in the phrase MarkingATopic (no
spaces). Then click on the OK button.

3. That's it. You have created a topic called 'MarkingATopic'

Remember... is for making a Topic.

Before we move on, let's just create a #LJLink#linkLink to our topic. You will notice
that the word link in the previous sentence is a green colour. This is because it has
already been marked up as a link.

Now its is your turn:

You are going to mark some text and make it a link. Do the following steps:

1. Select the followng text #LJLink#'Marking a link'Link. Selecting text is
done by dragging the mouse cursor so that the text is highlighted in
reverse colours .

2. Good. Now click on the 'L' icon in the toolbar. A dialog box will appear
in the centre of your screen. Simply type in Link.
Then click on the OK button.
(Since a topic called Link already exists it will appear in the list and can
be selected by the mouse to save a bit of typing.)

3. Excellent. Read the next two sections: 'What is a topic?' and 'What is a
link?' and you are then ready to create your help file.

Remember... is for making a Link.
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## Topic $$ What is a Topic KK Z Topics;Topic;What is;Colour;Green;Blue;Inserting;Deleting;Editing#What is a Topic
?
A topic is a chunk of information that is displayed on the screen when viewed by
Microsoft Help. If the chunk of information is larger than the screen, scroll bars will
appear. The end of a topic is marked by the beginning of the next topic or the end of
the document.

Tip: Besides using the 'T' icon on the toolbar to mark a topic you can use a
keyboard shortcut by pressing 'Ctrl+Shift+T'. And if you prefer to use the
menus you will find the topic function on the Edit and Insert menu items.

Tip: The menu items added by EasyHelp can easily be recognised - they all have a
'© ' to the left of the item text.

With the topic function you can mark a new topic or edit an existing one. If your text
cursor is on an existing topic you will be able to edit the topic.

One more thing to remember about a topic is that there are two types:

1. A jump topic. This will be marked in a green colour in your document. A jump
topic is the most common and can be thought of as a jump to another position
in the help file.

2. A popup topic. This will be marked in a blue colour in your document. A
popup topic is normally used to display a smaller amount of information, and is
frequently used for definitions and glossary type items.

More about popup topics later.

Remember... the shortcut key combination
for making or editing a topic is:

'Ctrl+Shift+T'.

EasyHelp Tutorial

Page 1



## Link $$ What is a Link KK Z Topics;Link;What is;Colour;Blue;Green;Inserting;Deleting;Editing#What is a Link?
A link is a branch to a topic. It is normally a word or phase in your document.

Tip: Besides using the 'L' icon on the toolbar to mark a topic you can use a
keyboard shortcut by pressing 'Ctrl+Shift+L'. And if you prefer to use the
menus you will find the link function on the Edit and Insert menu items.

Tip: Most of the shortcut keys used by EasyHelp use the same technique of holding
'Ctrl+Shift' down (use your thumb and finger) and pressing a single letter.

With the link function you can mark a new link or edit an existing one. If you have
marked the text of an existing link you will be able to edit the link.

Like topics, there are two types of link:

1. A jump link. This will be marked in a green colour in your document. A jump
link is the most common and can be thought of as a jumping to another
position in the help file.

When viewed by Microsoft Help a jump link will be underlined with a
continuous line.

2. A popup link. This will be marked in a blue colour in your document.

When viewed by Microsoft Help a popup link will be underlined with a dotted
line.

More about popup links later.

Remember... the shortcut key combination
for making or editing a link is:

'Ctrl+Shift+L'.
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## Creating $$ Creating your help file KK Z Topics;Creating;Help;File;Processing;Building#Creating your help file
OK. enough of the theory, let's create our help file. Once you have 'marked up' your
document the hard bit is over! Two steps need to be followed to build your help file.
We are going to do that now, even though we have not quite finished marking up our
document.

Let's do it:

You are going to process your document and then build your help file. Do the
following steps:

1. Click on the 'P' icon on the toolbar. A configuration dialog box will
appear in the centre of your screen. Simply click on the OK button.
Wait while your document is processed.

2. Click on the 'B' icon on the toolbar. A configuration dialog will appear in
the centre of your screen. Simply click on the OK button.
A window opens showing the progress of your build. When the build has
finished, click on OK and you will be able to view your built help file.

Close the help file and you will return to this tutorial document.

3. That's it. You have built your help file.

Remember... is for Processing your
document.

Remember... is for Building your help
file.
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## More $$ Ther must be more to it! KK Z Topics;More;Easy#There must be more to it!
Well there is ... but not much more. Topics and links are the main concepts that you
need to grasp. You will notice that any document can be marked up as a hypertext file
whilst leaving the document in its original form (except for colour changes!). This is
exactly what EasyHelp was designed for: to save trees, by enabling manuals,
procedure documents, in fact anything, to be produced in hypertext form.

The best way to learn more about EasyHelp is to work with it for a while. It will
eventually become a normal part of your document processing process. For more
detailed information and help on specific parts please use the on line help file that was
installed with EasyHelp.

Anyway there are a few more areas to explore:

Graphics
Configuration
Popup Topics
Popup Links
Deleting Mark-up

These will be covered in the next few pages, simply read through the text to gain an
overview of these features. Then to complete the tutorial, we will go through some
exercises in the section entitled 'Exercises to Complete the Tutorial'.
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## Graphics $$ Using graphics in your help file KK Z Topics;Graphics;Using;Inserting;Editing;Deleting#Graphics
This is a picture of me. (Pretty handsome chap eh..) This graphic was inserted
as a picture using normal Word facilities. It will show up the same in the built
help file.

bmc JAMES.BMP This will also be a picture of me that will appear in the built
help file. It was inserted using the 'G' icon on the toolbar. If wish to change the
graphic, highlight the [] markers and click on the 'G' icon. The advantage of
this method of including graphics is that the graphic does not increase the size
of your Word document. Also, special graphics files, called 'segmented hyper
graphics' (.shg files), can be included in this way.

#LJPictureOfMe#bmc JAMES.BMPPictureOfMe Click me. This will jump to a yet
another picture of me. The picture you will see is an example of the '.shg' type
files. These special graphics files can have 'hot spots' that jump to other topics
when you click on them.

You will also note that the [] markers are in green, this is because they have
been marked up as a link to the topic containing a picture of me.

Remember... is for adding or editing a
Graphic.
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## PictureOfMe $$ Picture Of Me KK Z Topics;Picture;Me;Graphics;Inserting;Editing#Picture of Me - Click on my
eyes!
bmc JAMES.SHG

EasyHelp Tutorial

Page 1



## Configuration $$ Configuring EasyHelp KK Z Topics;Configuration;Dialogs;Projects#Configuration
EasyHelp can be configured from within Word. To bring up the configuration dialog
click on the icon on the toolbar. The details of the configuration dialog are
covered more fully in the on-line help, but some of the main points are described here.
Global SettingsThe paths section give the location of the EasyHelp system files and the Help

Compiler. The name of the help compiler is specified here.The format options allow you to enforce a standard style to the topic headings. IF
you wish to control the format of the headings to topics, uncheck this option.The other options allow you to always show the configuration dialog before
processing the document or building the help file. You will probably want to
uncheck this option as you become more experienced with using EasyHelp.

ProjectsThe project options allow you to work on different projects and have unique
settings for each project. Two projects exist when you first install EasyHelp,
default and tutorial.

Tip: The default project settings are used as the basis of any new projects that you
create. Change the default settings to suit your needs.

Project Name. Give a name to your project. A name must be eight characters or
less. Your help file will have this name.Help Title. The title of your help file.First Help Topic. The name of the help topic to be used as the contents page of
your help file.Markup Details File. Don't worry too much about this now, but as you build more
sophisticated help files this file is used to specify a more details about your help
topics. For example a long description of your help topics and keywords that can
be used to search for those topics.
Help Output Path. This is where your built help file with be put
Help Input Path. This is where your Markup Details File resides and your
processed documents.
Graphics Path. This is where any graphics files that are used by your help files
reside.

Remember... is for Configuring
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## PopupTopics $$ Popup Topics KK Z Popups;Popup;Topics;Blue;Colour;Inserting;Deleting;Editing#Popup Topics
You will notice that the title of this section is in blue. This indicates that it is a Popup
Topic rather than a Jump Topic.
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## PopupLinks $$ Popup Links KK Z Popups;Popup;Links;Blue;Colour;Inserting;Deleting;Editing#Popup Links
A popup link is also coloured blue in the document. In the help file it will be
underlined with a dotted line. For example: see #LPPopupTopics#Popup
TopicsPopupTopics
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## Deleting $$ Deleting EasyHelp Markup KK Z Popups;Deleting;Markup;Using#Deleting Mark-up
Mark-up can be deleted in a paragraph by positioning the text cursor anywhere in the
paragraph and using the shortcut keys 'Ctrl+Shift+D', or by selecting '© Delete
EasyHelp Markup' from the Edit menu.

Graphic mark-up can be deleted by simply deleting the [] markers.
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## Preparing $$ Preparing to use EasyHelp KK Z Popups;Preparing;EasyHelp;Templates;Using#Preparing to Use EasyHelp
In order to use EasyHelp on new or existing document you will need to attach the
EasyHelp template (called EasyHelp.dot) to your document. For new documents you
will be prompted for the name of the template to use - simply choose EASYHELP
from the list. For existing documents you will need to attach the EasyHelp template to
your document (use the File | Template... menu option).
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## Exercises $$ Exercises for you to do KK Z Topics;Exercises;Hard;Work#Exercises to Complete the Tutorial.
To reinforce your understanding of EasyHelp please take a little time to do the
following exercises:

1. Mark as Topics any of the headings not already marked up. You chose whether to
make them jumps or popups. You choose the identifying names.

2. Mark the following lines as Links. You choose whether to make them jumps or
popups. And you choose which Topic to jump to.

#LJTopic#What is a Topic?Topic
#LJLink#What is a Link?Link
#LJCreating#Creating your help fileCreating
#LJMore#There must be more to it!More
#LJGraphics#GraphicsGraphics
#LJConfiguration#ConfigurationConfiguration
#LPPopupTopics#Popup TopicsPopupTopics
#LPPopupLinks#Popup LinksPopupLinks
#LPDeleting#Deleting Mark-upDeleting
#LJContents#Back to the first pageContents

Tip: If the Topic has been marked up as a jump, then make any link to it a jump
also. Similarly if the Topic has been marked up as a popup, then make any link
to it a popup also.Mark

3. Try reviewing your work by editing the Topics and Links in this document.

4. Try deleting some of the mark-up in this document, and then redo it. Select the
text. and then use the shortcut keys 'Ctrl+Shift+D' or select '© Delete EasyHelp
Markup' from the Edit menu.

5. This next exercise is a bit tricky, don't worry if you can not do it . What we need
to do is make this page of the document the contents page of the help file. From
this page we can then branch to all the other topics.

Select the configure EasyHelp option. Use the shortcut keys 'Ctrl+Shift+C' or
select '© Configure EasyHelp' from the Tools menu.

Now we need to edit the 'tutorial' project, by selecting the Edit... button.

Change the First Help Topic' from 'Contents' to 'Exercises'

Close the dialogs by selecting OK.

Remember... is for Configuring
EasyHelp.

6. Process this document. Use the shortcut keys 'Ctrl+Shift+P' or select '© Process
Markup' from the Tools menu.

7. Build the completed document. Use the shortcut keys 'Ctrl+Shift+B' or select '©
Build Help' from the Tools menu..

8. View any errors in the build process. Use the shortcut keys 'Ctrl+Shift+E' or
select '© View Build Errors' from the Help menu. There should not be any errors
of course!

EasyHelp Tutorial

Page 1



9. Browse through the EasyHelp file. To load the help file use the shortcut keys
'Ctrl+Shift+H' or select '© EasyHelp Help' from the Help menu.

That's it. We have finished the tutorial.
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